$re = '/(^[^\w]+)|([^\w]+$)/m';
$str = 'hello.
hello.world
,hello+world.;
...hello...world...
..hello12workd123.akfje.[]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);