re = /(^[^\w]+)|([^\w]+$)/m
str = 'hello.
hello.world
,hello+world.;
...hello...world...
..hello12workd123.akfje.[]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end