# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\D)0+//gm;t' <<< "abcd000324
abcd0034505
ABC012030"