$re = '/(?<=\D)0+/m';
$str = 'abcd000324
abcd0034505
ABC012030';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;