use strict;
my $str = 'abcd000324
abcd0034505
ABC012030';
my $regex = qr/(?<=\D)0+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";