package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*?(?:(?:[0-9]{2}[/-]){2}[0-9]{4}|[0-9]{4}(?:\h[0-9]{4}){2}).*`)
var str = `10/02/1992
10/02/1992 or 1992
10/1992
02/1992
1992
1234 5694 7487
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}