$re = '~.*?(?:(?:[0-9]{2}[/-]){2}[0-9]{4}|[0-9]{4}(?:\h[0-9]{4}){2}).*~m';
$str = '10/02/1992
10/02/1992 or 1992
10/1992
02/1992
1992
1234 5694 7487
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);