#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([A-Z][A-Za-z]+[/0-9]+)\s+(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}|unassigned)\s+([A-Z]+)\s+([A-Za-z]+)\s+(up|administratively down)\s+(up|down)"
Local $sString = "Interface IP-Address OK? Method Status Protocol" & @CRLF & _
"GigabitEthernet1 10.10.20.48 YES NVRAM up up " & @CRLF & _
"GigabitEthernet2 unassigned YES NVRAM administratively down down" & @CRLF & _
"GigabitEthernet3 unassigned YES NVRAM administratively down down" & @CRLF & _
"Loopback21 unassigned YES unset up up" & @CRLF & _
"Loopback2050 192.168.60.50 YES manual up up" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")