re = /([A-Z][A-Za-z]+[\/0-9]+)\s+(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}|unassigned)\s+([A-Z]+)\s+([A-Za-z]+)\s+(up|administratively down)\s+(up|down)/m
str = 'Interface IP-Address OK? Method Status Protocol
GigabitEthernet1 10.10.20.48 YES NVRAM up up
GigabitEthernet2 unassigned YES NVRAM administratively down down
GigabitEthernet3 unassigned YES NVRAM administratively down down
Loopback21 unassigned YES unset up up
Loopback2050 192.168.60.50 YES manual up up
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end