import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z][A-Za-z]+[/0-9]+)\\s+(\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}|unassigned)\\s+([A-Z]+)\\s+([A-Za-z]+)\\s+(up|administratively down)\\s+(up|down)";
final String string = "Interface IP-Address OK? Method Status Protocol\n"
+ "GigabitEthernet1 10.10.20.48 YES NVRAM up up \n"
+ "GigabitEthernet2 unassigned YES NVRAM administratively down down\n"
+ "GigabitEthernet3 unassigned YES NVRAM administratively down down\n"
+ "Loopback21 unassigned YES unset up up\n"
+ "Loopback2050 192.168.60.50 YES manual up up\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}