using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(public void GetAccess\(\w+.)([a-z_0-9]+)(\w+ \w+\))";
string substitution = @"$1$3";
string input = @"public void GetAccess(Person.prefixProperty prop)
{
////
}
public void GetAccess(Person.Property prop)
{
////
}
public void GetRootAccess(Person.prefixProperty prop)
{
////
}
public void GetAccess(Class.textProperty prop)
{
////
}";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}