$re = '/(public void GetAccess\(\w+.)([a-z_0-9]+)(\w+ \w+\))/m';
$str = 'public void GetAccess(Person.prefixProperty prop)
{
////
}
public void GetAccess(Person.Property prop)
{
////
}
public void GetRootAccess(Person.prefixProperty prop)
{
////
}
public void GetAccess(Class.textProperty prop)
{
////
}';
$subst = "$1$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;