// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(public void GetAccess\(\w+.)([a-z_0-9]+)(\w+ \w+\))").unwrap();
let string = "public void GetAccess(Person.prefixProperty prop)
{
////
}
public void GetAccess(Person.Property prop)
{
////
}
public void GetRootAccess(Person.prefixProperty prop)
{
////
}
public void GetAccess(Class.textProperty prop)
{
////
}";
let substitution = "$1$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}