# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\d{4}\s+\d{2}([A-Z ]*?[A-Z])\s*\d.*/$1/gm;t' <<< "0010 00LTT BOX PCS RH039349 0101113140 DE1 D 1
1210 02EXH BX PCS RH 060644 010111 DL5 D 1
0010 00PLATE BENT 039348 0101116201 DE1 B 1
0010 00PLATE BENT RH 039348 0101116201 DE1 C 1
0010 00ANGLE 038310 0101110200 DD1 B 1"