import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{4}\\s+\\d{2}([A-Z ]*?[A-Z])\\s*\\d.*";
final String string = "0010 00LTT BOX PCS RH039349 0101113140 DE1 D 1\n\n"
+ "1210 02EXH BX PCS RH 060644 010111 DL5 D 1\n\n"
+ "0010 00PLATE BENT 039348 0101116201 DE1 B 1\n\n"
+ "0010 00PLATE BENT RH 039348 0101116201 DE1 C 1\n\n"
+ "0010 00ANGLE 038310 0101110200 DD1 B 1";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}