use strict;
my $str = '0010 00LTT BOX PCS RH039349 0101113140 DE1 D 1
1210 02EXH BX PCS RH 060644 010111 DL5 D 1
0010 00PLATE BENT 039348 0101116201 DE1 B 1
0010 00PLATE BENT RH 039348 0101116201 DE1 C 1
0010 00ANGLE 038310 0101110200 DD1 B 1';
my $regex = qr/^\d{4}\s+\d{2}([A-Z ]*?[A-Z])\s*\d.*/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";