use strict;
my $str = 'IF ( fd1="","Not around",fd1 )
IF ( fd1="","Not found",fd1 )';
my $regex = qr/(\"[^\"]*?\")|\h/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";