re = /(\"[^\"]*?\")|\h/m
str = 'IF ( fd1="","Not around",fd1 )
IF ( fd1="","Not found",fd1 )'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result