using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"urn:epc:id:sgln:\d+\.\d+\.\d+";
string input = @"urn:epc:id:sgln:345344423.1345.143";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}