package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)urn:epc:id:sgln:\d+\.\d+\.\d+`)
var str = `urn:epc:id:sgln:345344423.1345.143`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}