$re = '/urn:epc:id:sgln:\d+\.\d+\.\d+/m';
$str = 'urn:epc:id:sgln:345344423.1345.143';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);