package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-Za-z]+\s*\([0-9\+\*\-\\\s]+\)`)
var str = `ABS((ABS(-48) - ABS(245 + 34 - 98))) + ABS(ABS(10 + 9)) > 100`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}