$re = '/[A-Za-z]+\s*\([0-9\+\*\-\\\\\s]+\)/m';
$str = 'ABS((ABS(-48) - ABS(245 + 34 - 98))) + ABS(ABS(10 + 9)) > 100';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);