re = /[A-Za-z]+\s*\([0-9\+\*\-\\\s]+\)/m
str = 'ABS((ABS(-48) - ABS(245 + 34 - 98))) + ABS(ABS(10 + 9)) > 100'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end