import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " ^P\n"
+ " (?=\\w*\\d)\n"
+ " (?:(?<years>\\d+)Y|Y)?\n"
+ " (?:(?<month>\\d+)M|M)?\n"
+ " (?:(?<days>\\d+)D|D)?\n"
+ " (?:\n"
+ " T\n"
+ " (?:(?<hours>\\d+)H|H)?\n"
+ " (?:(?<minutes>\\d+)M|M)?\n"
+ " (?:\n"
+ " (?<seconds>\n"
+ " \\d+\n"
+ " (?:\n"
+ " \\.\n"
+ " \\d{1,2}\n"
+ " )?\n"
+ " )S\n"
+ " |\n"
+ " S\n"
+ " )?\n"
+ " )?$";
final String string = "P1Y3M2DT3H3.12S";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}