import Foundation
let pattern = #"""
^P
(?=\w*\d)
(?:(?<years>\d+)Y|Y)?
(?:(?<month>\d+)M|M)?
(?:(?<days>\d+)D|D)?
(?:
T
(?:(?<hours>\d+)H|H)?
(?:(?<minutes>\d+)M|M)?
(?:
(?<seconds>
\d+
(?:
\.
\d{1,2}
)?
)S
|
S
)?
)?$
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = #"P1Y3M2DT3H3.12S"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}