using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$\.test[^'""]*(?:""([^""\\]*(?:\\.[^""\\]*)*)""|'((?:[^'\\]*(?:\\.[^'\\]*)*))').*";
string input = @"$.test(""I am do'in testing"")
$.test('I am do""in testing')";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}