re = /\$\.test[^'"]*(?:"([^"\\]*(?:\\.[^"\\]*)*)"|'((?:[^'\\]*(?:\\.[^'\\]*)*))').*/
str = '$.test("I am do\'in testing")
$.test(\'I am do"in testing\')'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end