package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\$\.test[^'"]*(?:"([^"\\]*(?:\\.[^"\\]*)*)"|'((?:[^'\\]*(?:\\.[^'\\]*)*))').*`)
var str = `$.test("I am do'in testing")
$.test('I am do"in testing')`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}