$re = '/(?:(.{1,40})([\s-]|$))|(.{1,40})/m';
$str = 'Produktbezeichnung: Sub TWU 3-0123 (1x230 V, 50 Hz)
Qmax = 7
sadas dfdsfs dfvsdvdfdsfaafdsfsdfsfsdffsdff
asdfdgdgdfggggggggggggggggggggggggggggggg';
$subst = "$1$3|";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;