import Foundation
let pattern = #"(?:(.{1,40})([\s-]|$))|(.{1,40})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Produktbezeichnung: Sub TWU 3-0123 (1x230 V, 50 Hz)
Qmax = 7
sadas dfdsfs dfvsdvdfdsfaafdsfsdfsfsdffsdff
asdfdgdgdfggggggggggggggggggggggggggggggg
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$3|"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)