re = /(?<=Contract Nu:\s)(\S+)/m
str = 'Phone Number: xxx xxx xxx
Contract Nu: 3471/207/sE
PPN B (da/ne*): Yes'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end