#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\bhref\s*=\s*(?:"([^"]*)"|'([^']*)'|([^\s>]*))"
Local $sString = "<a href='javascript:alert(1)' sometags>click me</a>" & @CRLF & _
"<a href="javascript:alert(1)" sometags>click me</a>" & @CRLF & _
"<a href=javascript:alert(1) sometags>click me</a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")