$re = '/\bhref\s*=\s*(?:"([^"]*)"|\'([^\']*)\'|([^\s>]*))/i';
$str = '<a href=\'javascript:alert(1)\' sometags>click me</a>
<a href="javascript:alert(1)" sometags>click me</a>
<a href=javascript:alert(1) sometags>click me</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);