re = /\bhref\s*=\s*(?:"([^"]*)"|'([^']*)'|([^\s>]*))/i
str = '<a href=\'javascript:alert(1)\' sometags>click me</a>
<a href="javascript:alert(1)" sometags>click me</a>
<a href=javascript:alert(1) sometags>click me</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end