#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\+7 999 888-66-55[\s\S]+?)(?=\n\+\d+ \d{3})"
Local $sString = "+7 999 888-77-66 Фамилия имя" & @CRLF & _
"здесь текст от Фамилия имя" & @CRLF & _
"здесь текст от Фамилия имя" & @CRLF & _
"здесь текст от Фамилия имя" & @CRLF & _
"+7 999 888-66-55 имя55 фамилия55" & @CRLF & _
"текст 1 написал имя55 фамилия55" & @CRLF & _
"текст 1 написал имя55 фамилия55" & @CRLF & _
"текст 1 написал имя55 фамилия55" & @CRLF & _
"+7 999 888-44-33 Ник" & @CRLF & _
"здесь писал юсер Ник" & @CRLF & _
"здесь писал юсер Ник" & @CRLF & _
"+7 999 888-22-11 Имя Фамилия" & @CRLF & _
"а здесь ИмяФамилия написал" & @CRLF & _
"а здесь ИмяФамилия написал" & @CRLF & _
"+7 999 888-77-66 СуперНик" & @CRLF & _
"Супер Ник тоже писала" & @CRLF & _
"+7 999 888-77-66 Никкккк" & @CRLF & _
"ну и никкккк" & @CRLF & _
"+7 999 888-66-55 имя55 фамилия55" & @CRLF & _
"текст 2 написал имя55 фамилия55" & @CRLF & _
"текст 2 написал имя55 фамилия55" & @CRLF & _
"+7 999 888-22-11 Имя Фамилия" & @CRLF & _
"здесь текст 2 от Фамилия имя" & @CRLF & _
"здесь текст 2 от Фамилия имя" & @CRLF & _
"здесь текст 2 от Фамилия имя" & @CRLF & _
"+7 999 888-77-66 КтоТоИзЧата" & @CRLF & _
"минут 20 назад что то с проводами" & @CRLF & _
"+7 999 888-22-11 Имя Фамилия" & @CRLF & _
"ТраЛа лал лал" & @CRLF & _
"+7 999 888-77-66 КтоТоИзЧата" & @CRLF & _
"трулу лул лул лу" & @CRLF & _
"+7 999 888-22-11 Имя Фамилияа" & @CRLF & _
"здесь ИмяФамилия опять написал 1" & @CRLF & _
"здесь ИмяФамилия опять написал 2" & @CRLF & _
"здесь ИмяФамилия опять написал 3" & @CRLF & _
"здесь ИмяФамилия опять написал 4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")