import Foundation
let pattern = #"(\+7 999 888-66-55[\s\S]+?)(?=\n\+\d+ \d{3})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
+7 999 888-77-66 Фамилия имя
здесь текст от Фамилия имя
здесь текст от Фамилия имя
здесь текст от Фамилия имя
+7 999 888-66-55 имя55 фамилия55
текст 1 написал имя55 фамилия55
текст 1 написал имя55 фамилия55
текст 1 написал имя55 фамилия55
+7 999 888-44-33 Ник
здесь писал юсер Ник
здесь писал юсер Ник
+7 999 888-22-11 Имя Фамилия
а здесь ИмяФамилия написал
а здесь ИмяФамилия написал
+7 999 888-77-66 СуперНик
Супер Ник тоже писала
+7 999 888-77-66 Никкккк
ну и никкккк
+7 999 888-66-55 имя55 фамилия55
текст 2 написал имя55 фамилия55
текст 2 написал имя55 фамилия55
+7 999 888-22-11 Имя Фамилия
здесь текст 2 от Фамилия имя
здесь текст 2 от Фамилия имя
здесь текст 2 от Фамилия имя
+7 999 888-77-66 КтоТоИзЧата
минут 20 назад что то с проводами
+7 999 888-22-11 Имя Фамилия
ТраЛа лал лал
+7 999 888-77-66 КтоТоИзЧата
трулу лул лул лу
+7 999 888-22-11 Имя Фамилияа
здесь ИмяФамилия опять написал 1
здесь ИмяФамилия опять написал 2
здесь ИмяФамилия опять написал 3
здесь ИмяФамилия опять написал 4
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)