use strict;
my $str = '+7 999 888-77-66 Фамилия имя
здесь текст от Фамилия имя
здесь текст от Фамилия имя
здесь текст от Фамилия имя
+7 999 888-66-55 имя55 фамилия55
текст 1 написал имя55 фамилия55
текст 1 написал имя55 фамилия55
текст 1 написал имя55 фамилия55
+7 999 888-44-33 Ник
здесь писал юсер Ник
здесь писал юсер Ник
+7 999 888-22-11 Имя Фамилия
а здесь ИмяФамилия написал
а здесь ИмяФамилия написал
+7 999 888-77-66 СуперНик
Супер Ник тоже писала
+7 999 888-77-66 Никкккк
ну и никкккк
+7 999 888-66-55 имя55 фамилия55
текст 2 написал имя55 фамилия55
текст 2 написал имя55 фамилия55
+7 999 888-22-11 Имя Фамилия
здесь текст 2 от Фамилия имя
здесь текст 2 от Фамилия имя
здесь текст 2 от Фамилия имя
+7 999 888-77-66 КтоТоИзЧата
минут 20 назад что то с проводами
+7 999 888-22-11 Имя Фамилия
ТраЛа лал лал
+7 999 888-77-66 КтоТоИзЧата
трулу лул лул лу
+7 999 888-22-11 Имя Фамилияа
здесь ИмяФамилия опять написал 1
здесь ИмяФамилия опять написал 2
здесь ИмяФамилия опять написал 3
здесь ИмяФамилия опять написал 4';
my $regex = qr/(\+7 999 888-66-55[\s\S]+?)(?=\n\+\d+ \d{3})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}