const regex = /(\w+)\s+\1/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+)\\s+\\1', 'gu')
const str = `этот этот текст содержит несколько несколько повторяющихся слов слов через разное разное количество пробельных символов, а также однокоренные слова: красный, красноватый, красненький.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}