import re
regex = re.compile(r"(\w+)\s+\1", flags=re.UNICODE)
test_str = "этот этот текст содержит несколько несколько повторяющихся слов слов через разное разное количество пробельных символов, а также однокоренные слова: красный, красноватый, красненький."
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")