$re = '/(\w+)\s+\1/u';
$str = 'этот этот текст содержит несколько несколько повторяющихся слов слов через разное разное количество пробельных символов, а также однокоренные слова: красный, красноватый, красненький.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);