#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-z0-9\.\-]+@[A-z0-9\.\-]+\.[A-z0-9]{2,3}$"
Local $sString = "muratsanturkey2001@hotmail.com" & @CRLF & _
"muratsab4@gmail.com" & @CRLF & _
"murat.san@x2.gov" & @CRLF & _
"Murat-San.Hero@outlook.x2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")