const regex = new RegExp('^[A-z0-9\\.\\-]+@[A-z0-9\\.\\-]+\\.[A-z0-9]{2,3}$', 'gm')
const str = `muratsanturkey2001@hotmail.com
muratsab4@gmail.com
murat.san@x2.gov
Murat-San.Hero@outlook.x2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}