use strict;
my $str = 'Ścieki';
my $regex = qr/Ścieki/p;
my $subst = 'Ścieki';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";