import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([ap]\\.m\\.)\\h(?=–\\h\\d+(:\\d\\d)?\\h\\1)";
final String string = "11 a.m. – 10:30 a.m.\n"
+ "6 a.m. – 9 a.m. \n"
+ "5 p.m. – 8:15 p.m.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}