import re
regex = re.compile(r"([ap]\.m\.)\h(?=–\h\d+(:\d\d)?\h\1)", flags=re.MULTILINE)
test_str = ("11 a.m. – 10:30 a.m.\n"
"6 a.m. – 9 a.m. \n"
"5 p.m. – 8:15 p.m.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")