re = /([ap]\.m\.)\h(?=–\h\d+(:\d\d)?\h\1)/m
str = '11 a.m. – 10:30 a.m.
6 a.m. – 9 a.m.
5 p.m. – 8:15 p.m.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end