using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*?\|[А-Я][а-я]{2,}\|[А-Я][а-я]{2,}\|";
string input = @"email1@pochta.ru|Имя|Фамилия|2|1965-10-06|
email2@pochta.ru|дебильное имя|дебилЬная ФамилиZ|2|1976-04-03|Россия, Московская обл.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}