$re = '/^.*?\|[А-Я][а-я]{2,}\|[А-Я][а-я]{2,}\|/';
$str = 'email1@pochta.ru|Имя|Фамилия|2|1965-10-06|
email2@pochta.ru|дебильное имя|дебилЬная ФамилиZ|2|1976-04-03|Россия, Московская обл.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);