package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^.*?\|[А-Я][а-я]{2,}\|[А-Я][а-я]{2,}\|`)
var str = `email1@pochta.ru|Имя|Фамилия|2|1965-10-06|
email2@pochta.ru|дебильное имя|дебилЬная ФамилиZ|2|1976-04-03|Россия, Московская обл.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}